поставки оборудования
ICQ: 238-612
Skype: lantorg1
+38 (057) 780 - 40 - 63
+38 (095) 762 - 44 - 96
+38 (063) 638 - 79 - 24
+38 (067) 961 - 56 - 02
г. Харьков, Московский проспект, 122

Настройка IPTV на Mikrotik

Настройка IPTV на MikroTik

Для примера настройки IPTV мы взяли Mikrotik RB2011UiAS-2HnD. Не совсем домашний роутер, конечно, но настройка на других устройствах принципиально ничем отличаться не будет.

Содержание:

  1. Reset Configuration роутера.
  2. Обновляем ПО роутера (добавляем пакет для IPTV).
  3. Настройка IGMP Proxy.
  4. Добавляем исключения Firewall.
  5. Настройка Wi-Fi.

Сброс настроек точки доступа

Этот пункт необязателен. Если вы настраиваете IPTV на роутере с рабочими настройками, которые вы делали ранее, то выполнять нижеописанные действия не нужно. Не помешает также сделать бекап конфигурации.

Однако иногда, если во время настройки IPTV на МикроТик что-то пошло не так, лучший выход - это "обнулить" конфигурацию и сделать все заново.

Сбросить настройки к заводским можно тремя способами:

Программно - заходим в WinBox, открываем меню System и делаем Reset Configuration.

 Механически: зажимаем кнопку Reset на вашем Mikrotik и ждем, пока роутер не перезагрузится. (На большинстве Mikrotik советуем зажимать кнопку ДО включения оборудования, и, не отпуская держать около 10-ти секунд после включения)

 Reset Configuration в меню самого роутера (на экране настройки). Актуально только при наличии сенсорного экрана на роутере.

Обновление RouterOS (добавление пакета для IPTV)

Обновление необходимо для того, чтобы установить дополнительный пакет для IPTV.

Заходим на сайт Mikrotik, ищем в списках линейку вашей модели и скачиваем последнюю версию прошивки для нее. Обратите внимание, выбираем не прошивку с основными пакетами (main), а с дополнительными (extra):

 

Открываем WinBox, заходим на роутер (советуем заходить изначально по мак-адресу, это облегчит дальнейший процесс настройки). Чтобы обновить ПО роутера, идем в меню Files.

Открываем его и перетаскиваем в окно Files наш скачанный файл из распакованного архива под названием multicast-x.xx-mipsbe.npk.

 

Пакет добавлен и после этого мы перезагружаем оборудование в меню SystemReboot.

Роутер перезагрузится и обновит прошивку. Процесс может занять до 5-ти минут. Питание в это время отключать не следует!

После перезагрузки открываем System - Packages и смотрим, появился ли модуль multicast.


Если таковой имеется, значит, вы все сделали правильно.

Настройка IGMP Proxy

Открываем в меню MikroTik Routing - IGMP Proxy. Нам нужно добавить новый интерфейс, для этого кликаем на плюс (как указано на скрине).

В новом интерфейсе, в поле Interface выбираем порт, по которому у нас поступает интернет, в нашем случае это ether2-master и устанавливаем галочку галочку Upstream, как на скриншоте:

Чуть ниже в поле Alternative Subnets следует указать альтернативные подсети. В том случае, если вы не знаете, что туда вписывать, попробуйте самые распространенные варианты: 10.0.0.0/8; 172.16.0.0/12; 192.168.0.0/16.


В крайнем случае можно оставить и нули, но лучше все же найти нужную подсеть, чтобы роутер не обращался ко всему интернету.

Подтверждаем изменения, нажимаем OK.

Создаем еще один интерфейс, кликая по синему плюсу, но теперь мы не ставим галочку напротив Upstream и при этом выбираем порт тот, на который мы будем перебрасывать IPTV - то есть тот, к которому подключено устройство, на котором мы будем смотреть IPTV. 

В нашем случае это bridge, потому что к нему подключен стационарный ПК.

То есть в первом случае мы указывали порт, куда входят данные, а теперь – откуда выходят.

После мы нажимаем кнопку Settings и ставим галочку напротив Quick Leave. Делаем мы это для того, чтобы иметь возможность быстро переключаться между каналами.

 

Настройка Firewall

Настраиваем  наш Firewall, который не пропускает IPTV на данный момент, для этого мы создаем новый терминал, нажимаем New Terminal и открывается вот такое окно:

 

Теперь мы должны выполнить в этой консоли несколько команд:

/ip firewall filter add action=accept chain=input comment="Allow IGMP" disabled=no in-interface=ether2-master protocol=igmp

/ip firewall filter add action=accept chain=input comment="IPTV UDP incoming" disabled=no dst-port=1234 in-interface=ether2-master protocol=udp

/ip firewall filter add action=accept chain=forward comment="IPTV UDP forwarding" disabled=no dst-port=1234 protocol=udp

1234 – порт неофициально зарегистрированный для передачи потокового видео и IPTV

ether2-master - это интерфейс, на который приходит IPTV от провайдера.

Далее нужно в меню IP выбрать пункт  Firewall и перейти на вкладку Filter Rules. Мы создали исключающие правила, и чтобы они работали, они должны быть выше запрещающих. Перетягиваем их вверх с помощью мыши.

Настройка Wi-Fi

В случае, если вы раздаете или собираетесь раздавать IPTV посредством Wi-Fi нужно добавить дополнительные настройки. Для этого открываем по порядку:

После нажатия кнопки Advanced Mode появляются дополнительные параметры:

  • В поле WMM Support ставим enabled - включаем поддержку передачи multimedia по Wi-Fi. 
  • В поле Multicast Helper ставим full. Этот параметр включает отправку мультикаст клиентам, сидящим на Wi-Fi.

Все, подтверждаем кнопкой OK и наслаждаемся просмотром программ.

Осталось только проверить работоспособность нашей конфигурации. Мы использовали для этого IPTV плеер, предварительно загрузив лист каналов для нашего провайдера (Велтон Телеком) в настройках плеера. 


Мы можем видеть, что наша настройка полностью работоспособна. Приятного просмотра!


Оцените, пожалуйста, полезность/интересность статьи. Нам важно ваше мнение!

Оценка:   4.2 (голосов 5)
Дата публикации: 01.11.2016
Поделиться с друзьями:                                                                            

Также советуем почитать:



Комментарии

  • Михаил 16.06.2017, 16:34
    Все заработало на hap lite, спасибо, hd каналы работают без артефактов, iptv идет на телек по проводу, по wi-fi - на комп и андроид приставку.
  • Евгений 21.04.2017, 12:43
    Владик, а как это сделать? У меня тоже iptv настроен и работает. Но тв забивает всю домашнюю сеть, тем более если HD показывает, то тупа страница яндекса на ноуте уже не грузится.
  • Vlad 06.04.2017, 15:21
    Сделал все по инструкции, через кабель все работает по Wi-Fi нет картинки вообще. Может что-то не так делаю...
    /routing igmp-proxy pr
    quick-leave: yes
    query-interval: 1m
    query-response-interval: 10s
    /routing igmp-proxy interface print detail
    Flags: X - disabled, I - inactive, D - dynamic, U - upstream
    0 U interface=ether1-gateway threshold=1 alternative-subnets=0.0.0.0/0 upstream=yes

    1 interface=bridge-local threshold=1 alternative-subnets="" upstream=no
    /interface wireless
    set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-Ce disabled=no distance=indoors frequency=2442 hw-protection-mode=rts-cts mode=\
    ap-bridge multicast-helper=full security-profile=profile1 ssid=XX tx-power=12 tx-power-mode=all-rates-fixed wireless-protocol=802.11 wmm-support=\
    enabled
  • Дмитрий 20.02.2017, 14:50
    Андрей, да, для того чтобы настроить одному или нескольким клиентам IPTV необходимо использовать мультикаст (получение определенной группой пользователей), к сожалению, по Wi-Fi бывают зависания иногда (так как битрейт некотрых каналов может достигать 20 мб), в такой ситуации могу посоветовать Вам использовать Plc адаптеры, чтобы не прокладывать кабель и благодаря им не будет обрывов связи.
  • Андрей 17.02.2017, 14:47
    Подскажите, как оптимально настроить айпитв мультикаст по вайфай. Все сделал по инструкции, картинка есть, но смотреть не возможно, сыпется.

    Как подстроить чтоб лить только определенному клиенту ? Или двум клиентам ?
    Спасибо.
  • Владик 27.11.2016, 10:02
    andrey_als, а кто вас заставляет лить мультикаст в bridge?! Выбери нужный порт, и лей только в него.

    Александр, так же и по Wi-Fi, зачем лить всем. Лей только определённому клиенту, выбирая по IP или MAC.

    Елси не можешь готовить Mikrotik, то и не покупай его.
  • Владимир 01.11.2016, 18:36
    Я так думаю это не надо 99,9 % пользователей данной приблуды. Основное ее назначение ловить интернет там где другого нет. А скорости ей много не дадут дабы не создавать конкуренцию ADSL, волокну и т.д.
  • Александр 01.11.2016, 14:25
    Более того, мультикаст выливается всем wifi-клиентам. Если к wifi подключено одно устройство - то еще как-то работает. Если больше - все начинает лагать и сыпать.
    Микротик столько лет не может сделать нормальный igmp-snooping для работы iptv, который есть в большинстве других роутеров и свичей.
  • andrey_als 01.11.2016, 13:14
    IGMP Proxy на микротике без smart коммутатора работает плохо т.к льет мультикаст на все порты bridge включая wifi, забивая канал. лучше для iptv использовать другие роутеры

Написать комментарий

Ссылки на другие сайты из комментариев удаляются. Спасибо за понимание.


Подписаться на получение новостей
* обязательные поля
Не чаще 1 письма в неделю. Только полезная информация. Убедитесь сами – посмотрите наш архив рассылок.